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IXP120  
IXP120 Software 

QUICK START GUIDE 

Before You Begin 

Have the following available: 
• The IXP120 Software CD  
• Serial number and fixed address of each IXP121 Controller 
 

Computer Requirements 

Make sure your computer meets the following minimum hardware 
requirements: 
 
Component Minimum requirement 

Processor Pentium II, 600MHz 

RAM 256Mb 

Hard Disk 2Gb available space 

Graphics 1024 x 768 

Modem USB or Serial 

Ports USB and RS232 

Removable Storage CDROM Drive 

Operating System Microsoft Windows NT, 2000, or XP Pro 
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Where to Find Information 

Additional information is available in the following resources: 
 
• IXP120 Software Help—part of the IXP120 Software.  Help 

provides detailed information on all aspects of the IXP120 
System. 

• IXP120 Product Specification Catalogue—available at 
www.impro.net  

• How to Set Up the IXP120 Database on a Dedicated Server 
document—for advanced Users only 

 
 

Document Conventions 

The following conventions are used in this document: 
 

Note – indicates additional information 
 
 

Tip – indicates alternative methods to perform a task 
 
 

Important – indicates important information 
 
 

Warning – indicates potential danger to you or the 
product 

 

http://www.impro.net/
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Sequence of Operations 
 
 

Setup Flowchart 

Follow this sequence of steps to setup and configure the IXP120 
Software: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once the Software is installed, repeat steps 2 to 4 only, to configure 
a Site. 
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Install the Software 
 
Install the IXP120 Software as follows: 
 
1. Insert the IXP120 CD into your PC’s CD-ROM drive. 
2. Open My Computer. 
3. Right-click the CD-ROM drive icon. 
4. Select Install from the menu. 
5. Follow the onscreen instructions. 

Initialize the Software 

Before starting the IXP120 Software, ensure that the 
Registration Reader or the IXP121 Controller is connected 

to the Host PC. 
 
1. In your Windows operating system, choose Start > Programs > 

IXP120 > IXP120. 
2. Enter your Username and Password. 
3. The Application window displays. 
 

The default Username is: SYSDBA 
The default Password is: masterkey 

Configure COM Ports 

If a Registration Reader is present, proceed as follows: 
 
1. On the menu, select File > System. 
2. Select the Enable Registration Reader check box. 
3. Select the COM port used for the Registration Reader. 
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If no Registration Reader is present, proceed as follows: 
 
1. On the menu, select File > System. 
2. Select the COM port used for the IXP121 Controller. 
 
If your IXP121 uses a modem, proceed as follows: 
 
1. On the menu, select File > System. 
2. Select the COM port used for Modem. 
 

Use Windows’ Device Manager to find out the COM port 
used by the IXP121 Controller or Registration Reader.  The 

following figure illustrates an ImproX hardware device connected to 
the Host PC. 
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Understand the Interface 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A - Menu bar  
Includes drop-down 
menus  

B - Toolbar 
Includes icon shortcuts 

C - Task pane  
Displays the selected task 

D - Monitor pane 
Provides real-time 
monitoring for: 
• Transactions 
• Alarms 
• Door Statuses 

E - Status bar 

F – Message Display 

G - Name of Active Site 

H - Active connection to 
database 
• Green light is active 
• Red light is inactive 

I - Active connection to 
communications bus 
• Green light is active 
• Red light is inactive 
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Toolbar Shortcuts 

In addition to the Menu, use the Toolbar to access important tasks. 
 
 
 
 
 
 

Using Help 

The IXP120 Software has an integrated context-sensitive Help 
system.  Information not covered in the guide is covered in Help.  Do 
one of the following to activate Help: 
 
• On the Toolbar, click the  button. 
• On the Menu, select Help > Help Topics. 
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Configure Sites 
 
 

Configuration Flowchart 

Do the following to configure a Site: 
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Create a New Site 

You must create a new Site by creating a new Site Directory Entry 
before you can configure your System.  To create a new Site, 
proceed as follows: 

 
1. On the menu, select Sites > Site Directory. 
2. Leave the Select Site Group option as Default Group. 
3. Click the  button. 
4. Enter a name for the Site. 
5. Select a Communication Port. 
6. If the Site uses a Modem, enter a Telephone number for the 

modem. 
7. Click the  button to save. 
 

The Controller’s fixed address is required for the Local 
Controller Port option. 

 
 The Local Controller Port option is suitable for RS232 and 

USB. 
 

For the Ethernet option, press F1 on your keyboard to 
launch Help. Refer to the Create a New Site topic by 

browsing Quick Start > Configuration in the Help navigation pane. 
 

Edit an Existing Site 

To edit an existing Site’s setup, proceed as follows: 
 
1. On the menu, select Sites > Site Directory. 
2. Select a Site from the Site Directory panel. 
3. Edit the Site’s setup options. 
4. Click the  button to save. 
 

1 
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Select a Site 

To configure a Site, proceed as follows: 
 
1. On the menu, select Sites > Select Site. 
2. Select a Site Group from the drop-down menu. 
3. Select a Site from the Select Site window. 
4. Click the  button to accept the selected Site, or click the  

button to cancel the operation. 
 

Set-up the IXP121 Controller 

To initiate communication with the Controller for the first time, 
proceed as follows: 
 
1. On the menu select Sites > Connect Site. 
2. When prompted, select Yes to perform AutoID. 
 
Alternatively, after connecting, proceed as follows: 
 
1. On the menu, select Hardware > Auto ID Units. 
2. When prompted, select Yes to perform AutoID. 
 
To configure the Controller, proceed as follows: 
 
1. On the menu, select Configuration > Controller. 
2. Select a Mode. 
3. Select the Daylight Savings checkbox if applicable. 
 
 
 



 

 
IXP321-0-0-GB-01 December 2006 Page 11 

 

Add Doors 

A Door is a single physical point of entry or exit.  A Door supports 
one or two Reader Terminals.  To add a Door, proceed as follows: 

 
 

1. On the menu, select Configuration > Doors. 
2. Click the  button. 
3. Enter a name for the Door in the Name textbox. For example: 

FrontDoor. 
4. Select the Entry Terminal. 
5. Select the Exit Terminal if required. 
6. Click the  button to save. 
7. Repeat steps 2 to 6 for additional Doors. 
 

Default Tag Mode is automatically assigned as the daily Day 
Mode for the Door. 

 
 

Create Access Groups 

Access Groups use Access Patterns to define times of access for 
one or more Doors.  Tag Holders with similar access requirements 
are assigned to a common Access Group.  To configure Access 
Groups, proceed as follows: 
 
1. On the menu, select Tags > Access Groups. 
2. Click the  button in the upper pane. 
3. Enter a name for the Access Group in the Name textbox. 
4. Click the  button to save the Access Group. 
 

You assign Tag Holders to their Access Groups in Step 4 - 
Add Tag Holders. 

 

3 

2 
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Create Access Patterns 

Access Groups use Access Patterns to determine times of access 
for each day of the week.  To add an Access Pattern to an existing 
Access Group, proceed as follows: 
 
1. Click the  button in the lower pane. 
2. Select the relevant days and times. 
3. Click the Doors tab. 
4. Select the relevant Doors from the right-hand panel. 
5. Click the  button to make the selected Door accessible. 
6. Click the  button to Save the Access Pattern. 
 
 

Configure Holidays 

Holidays are periods when access to Sites is restricted or 
customized.  To configure Holidays, proceed as follows: 
 
1. On the menu, select Configuration > Holidays. 
2. Enter a name for the Holiday in the Name textbox. 
3. Define the Start Date. 
4. Define the End Date. 
5. Click the  button to save. 
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Add Tag Holders 

To Add Tag Holders individually, proceed as follows: 
 
1. On the menu, select Tags > Tagholders. 
2. Click the  button. 
3. Enter a Tag Holder’s general information. 
4. Click the Tag tab. 

− Click the  button. 
− Present a Tag to the Registration Reader. 
− Click the Read Tag button. 
− Select a tag Level. 
− Select an Access Group. 

5. If the Tag Holder is an Operator, Click the Operator tab. 
− Select the This tagholder is an operator option. 
− Enter the Operator UserID. 

6. Click the  button to Save. 
 

The Tag Holder’s Last Name field is the only required field. 
 
 

Double-click an existing Tag Holder’s row to edit them. 
 
 
 
 
 
 
 
 
 
 

4 
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Connect to Site 

When you save configuration changes, they are saved to the Site 
database only – unless there is an active connection with the 
IXP121 Controller.   
 

The COM indicator on the status bar shows a green light if 
the Controller is connected.  Otherwise, the light is red. 

 
To connect to the Site Controller, proceed as follows: 
 
• On the menu, Select Sites > Connect Site. 
 
To disconnect from the Site Controller and database, proceed as 
follows: 
 
• On the menu, Select Sites > Disconnect Site. 
 

Start Full Upload 

A Full Upload writes data from the Site database to the IXP121 
Controller.  When you have completed configuring the Site, start a 
Full Upload as follows: 
 
• On the menu, select Configuration > Start Full Upload. 
 

The IXP121 Controller is temporarily off-line during a Full 
Upload and all data in the Controller buffer is erased. 

Therefore, the Controller canno process transactions. 
 

Always perform a Full Upload after the IXP121 
Controller has had a Firmware upgrade. 
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Advanced Features 
 
 

Door Mode Patterns 

Door Mode Patterns define operational times and parameters for a 
door.  They are configurable for each day of the week.  To define a 
new Door Mode Pattern, proceed as follows: 
 
1. On the menu, select Configuration > Doors. 
2. Click the Door Mode Patterns tab. 
3. Click the  button. 
4. Enter a name in the Pattern Name textbox. 
 

Add Pattern Time Slots 
Each Door Mode Pattern has up to eight Pattern Time Slots.  The 
first Pattern Time Slot has a default access period of 24 hours.  To 
add a Pattern Time Slot, proceed as follows: 
 
1. Change the End Time value of the first Pattern Time Slot and 

press [Enter] on your keyboard. 
2. A new Pattern Time Slot is created.  It has a Start Time value 

equal to the End Time value of the first Pattern Time Slot. 
3. Click on the other options of the Pattern Time Slot, and select 

values from a drop down menu. 
4. Click the  button to Save. 
 

The Default Tag Mode pattern is not configurable.  
Therefore, you cannot create Pattern Time Slots for it.  It is 

automatically assigned to new Doors. 
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Assign Door Mode Patterns to Doors 
To assign a Door Mode Pattern to a Door, proceed as follows: 
 
1. On the menu, select Configuration > Doors. 
2. Click the Door tab. 
3. Select a Door. 
4. Click the Day Mode button. 
5. Select an appropriate Door Mode Pattern from the drop-down 

menu. 
 
 

Add Tag Holders in Bulk 

To Add Tag Holders in bulk, proceed as follows: 
 
1. On the menu, Select Tags > Batch Add Tags. 
2. Select an Access Group. 
3. Select a Tag Level. 
4. Enter a Starting Tag Reference Number. 
5. Ensure the Batch Mode Auto Read option is selected. 
6. Click Start. 
7. Present your Tags to the Reader. 
8. Click Stop. 
9. Click the  button to Save. 
 

The Starting Tag Reference Number is a number you write 
on a Tag to identify it. 
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Reports 

Use the IXP120 Reports to view the following types of data: 
 
• Tag Holders’ location and access patterns 
• Zone occupancy and zone access patterns 
• In and out times, and duration of occupancy 
 
To view the IXP120 Reports, do one of the following: 
1. On the Toolbar, click the  button. 
2. On the Menu, select Reports > Web Reports. 
 
Reports are web-based.  Therefore, they are accessible from any 
workstation connected to the IXP120 Host PC’s network.  To access 
Reports in this manner, type the following URL into your Internet 
browser software: 
 
• http://localhost/webreports/servlet/net.impro.ipx1.web.webreport

s.SiteSelReport 
 

Replace localhost with the name of the Host PC. 
 
 

Web Reports Password 

Use a password to restrict access to Web Reports.  To do so, 
proceed as follows: 
 
1. On the menu, select File > Web Reports Password. 
2. Enter a password in the New Password textbox. 
3. Enter the same password in the Confirm Password textbox. 
4. Select the Enable Passwords For Web Reports checkbox. 
5. Click the  button to accept, or click the  button to cancel the 

operation. 

http://localhost/webreports/servlet/net.impro.ipx1.web.webreports.SiteSelReport
http://localhost/webreports/servlet/net.impro.ipx1.web.webreports.SiteSelReport
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Anti Passback (APB) 

An APB access control system does not accept a tag more than 
once in the same direction until that tag is processed in the opposite 
direction, and vice-versa.  This ensures the tag is not passed back 
to another person to gain entry.  To enable APB, proceed as follows: 
 
1. On the menu, select Configuration > Doors. 
2. Select a Door. 
3. Select one of the following APB Mode options: 

− Strict 
− Relax 

 
In Strict mode, Tag Holders must tag-in before they can 
tag-out, and vice-versa.  In Relax mode, Tag Holders can 

tag-out more than once, but can only tag-in if they have tagged out. 
 

APB Lockout Delay 
To set the amount of time that a Tag Holder is locked out after 
exiting an APB zone, proceed as follows: 
 
1. On the menu, select Configuration > Controller. 
2. Enter the APB Lockout Delay in minutes. 
 

Reset Anti-Passback 
Activating this function resets Anti-Passback for all Tags in all zones, 
to neutral.  The IXP121 system accepts any tag in any direction, but 
only for one transaction per tag.  To reset Anti-Passback for the 
connected Site, proceed as follows: 
 
• On the menu, select Hardware > Reset Anti-Passback. 
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Replace Units 

Replacing Controllers and Terminals is a complex process.  Details 
are provided in the IXP120 Help.  To access these details, open 
Help from the IXP120 Software and navigate to Advanced 
Features > Replace Units. 
 

Database Backup 

The IXP120 Software does not have an automated backup feature.  
Therefore, the IXP120 databases must be manually backed-up at 
regular intervals. 
 

We recommend backing up the IXP120 database on a 
monthly basis, or each time that there are changes made to 

the system. 
 

Ensure that the IXP120 Software is closed and inactive 
when you perform the backup procedure. 

 
To manually perform a backup, proceed as follows: 
 
1. In Windows, browse to the C:\IXP120\ folder. 
2. Select and copy the Database folder. 
3. Paste the Database folder to a secure location on your network, 

or archive it to CD, DVD, or tape, as per your company's backup 
policy. 
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USER NOTES 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This manual is applicable to the IXP120 Software Version 4.0. 

IXP321-0-0-GB-01 Issue 02 Dec 2006 
IXP120 Software\ENGLISH 

MANUALS\Quick Start 
Guide\IXP120qs-swm-en-02.doc 
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